Aktualizacje bezpieczeństwa

DSA-4184 sdl-image1.2

Debian Security - sob., 28/04/2018 - 00:00
security update

DSA-4182 chromium-browser

Debian Security - sob., 28/04/2018 - 00:00
security update

DSA-4183 tor

Debian Security - sob., 28/04/2018 - 00:00
security update

DSA-4181 roundcube

Debian Security - sob., 28/04/2018 - 00:00
security update

Drupal core - Critical - Remote Code Execution - SA-CORE-2018-004

Drupal - Security advisories - śr., 25/04/2018 - 18:13
Project: Drupal coreDate: 2018-April-25Security risk: Critical 17∕25 AC:Basic/A:User/CI:All/II:All/E:Theoretical/TD:DefaultVulnerability: Remote Code ExecutionDescription: 

A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. While SA-CORE-2018-002 is being exploited in the wild, this vulnerability is not known to be in active exploitation as of this release.

Solution: 

Upgrade to the most recent version of Drupal 7 or 8 core.

  • If you are running 7.x, upgrade to Drupal 7.59.
  • If you are running 8.5.x, upgrade to Drupal 8.5.3.
  • If you are running 8.4.x, upgrade to Drupal 8.4.8. (Drupal 8.4.x is no longer supported and we don't normally provide security releases for unsupported minor releases. However, we are providing this 8.4.x release so that sites can update as quickly as possible. You should update to 8.4.8 immediately, then update to 8.5.3 or the latest secure release as soon as possible.)

If you are unable to update immediately, or if you are running a Drupal distribution that does not yet include this security release, you can attempt to apply the patch below to fix the vulnerability until you are able to update completely:

These patches will only work if your site already has the fix from SA-CORE-2018-002 applied. (If your site does not have that fix, it may already be compromised.)

Reported By: Fixed By: 

DSA-4180 drupal7

Debian Security - śr., 25/04/2018 - 00:00
security update

DSA-4179 linux-tools

Debian Security - wt., 24/04/2018 - 00:00
security update

DSA-4178 libreoffice

Debian Security - pt., 20/04/2018 - 00:00
security update

DSA-4177 libsdl2-image

Debian Security - pt., 20/04/2018 - 00:00
security update

DSA-4176 mysql-5.5

Debian Security - pt., 20/04/2018 - 00:00
security update

Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2018-003

Drupal - Security advisories - śr., 18/04/2018 - 17:34
Project: Drupal coreDate: 2018-April-18Security risk: Moderately critical 12∕25 AC:Complex/A:User/CI:Some/II:Some/E:Theoretical/TD:DefaultVulnerability: Cross Site ScriptingDescription: 

CKEditor, a third-party JavaScript library included in Drupal core, has fixed a cross-site scripting (XSS) vulnerability. The vulnerability stemmed from the fact that it was possible to execute XSS inside CKEditor when using the image2 plugin (which Drupal 8 core also uses).

We would like to thank the CKEditor team for patching the vulnerability and coordinating the fix and release process, and matching the Drupal core security window.

Solution: 
  • If you are using Drupal 8, update to Drupal 8.5.2 or Drupal 8.4.7.
  • The Drupal 7.x CKEditor contributed module is not affected if you are running CKEditor module 7.x-1.18 and using CKEditor from the CDN, since it currently uses a version of the CKEditor library that is not vulnerable.
  • If you installed CKEditor in Drupal 7 using another method (for example with the WYSIWYG module or the CKEditor module with CKEditor locally) and you’re using a version of CKEditor from 4.5.11 up to 4.9.1, update the third-party JavaScript library by downloading CKEditor 4.9.2 from CKEditor's site.
Reported By: Fixed By: 

DSA-4175 freeplane

Debian Security - śr., 18/04/2018 - 00:00
security update

DSA-4174 corosync

Debian Security - wt., 17/04/2018 - 00:00
security update

DSA-4173 r-cran-readxl

Debian Security - pon., 16/04/2018 - 00:00
security update

DSA-4172 perl

Debian Security - sob., 14/04/2018 - 00:00
security update

DSA-4171 ruby-loofah

Debian Security - pt., 13/04/2018 - 00:00
security update

DSA-4169 pcs

Debian Security - śr., 11/04/2018 - 00:00
security update

DSA-4170 pjproject

Debian Security - pon., 09/04/2018 - 00:00
security update

DSA-4168 squirrelmail

Debian Security - ndz., 08/04/2018 - 00:00
security update

DSA-4167 sharutils

Debian Security - czw., 05/04/2018 - 00:00
security update